This is the official forum for the free, fan-made Age of Empires III modification, Wars of Liberty.

Welcome to the New Forum

We hope you enjoy the official new forum of the Wars of Liberty mod for Age of Empires III! Visit this thread to get acquainted with the new forum, and let us know if there's anything we can fix. Feel free to dismiss this message at any time by clicking the "X" in the top right corner.

Thanks!
The Wars of Liberty Team

Forum rules

  • Welcome to The Hospital! This forum is for bugs and error reporting.
  • The official language in this forum is English.
  • Be nice to other members, don't spam comments or smilies, and don't do anything illegal.
  • Posts that don't fit this forum will be moved or deleted.
 
User avatar
Hoffenheim
Topic Author
Whipped Slave
Whipped Slave
Posts: 5
Joined: Mon Jul 03, 2017 3:15 pm

Problems with Updater

Mon Jul 03, 2017 4:05 pm

Hello. I really enjoyed this mod but I have never got the updater to work so I hoped someone here might be of help. Just to add aswell, I have my firewall turned off when I install and I am connected to wifi and I meet the requirements. My java is also completely updated. So here are my error messages: 
http://imgur.com/uN4R9XZ
http://imgur.com/OoMNJqO
http://imgur.com/OU69jp7
http://imgur.com/mB75wND
http://imgur.com/afWMyA8

Thank you for your help.
 
User avatar
Daniel Pereira
Wars of Liberty Team
Wars of Liberty Team
Posts: 109
Joined: Sun Mar 12, 2017 2:20 am

Re: Problems with Updater

Mon Jul 03, 2017 6:23 pm

Hello!

If you are getting this error, this means that I forgot to update the alternate server! Sorry for that!

I'll update the files there and I'll give you a heads up once I finish doing so!

Thanks for the report and sorry for the trouble!

PS: The files are up at the alternate server! Let me know if you still get any errors!
Image
 
User avatar
Hoffenheim
Topic Author
Whipped Slave
Whipped Slave
Posts: 5
Joined: Mon Jul 03, 2017 3:15 pm

Re: Problems with Updater

Tue Jul 04, 2017 4:13 pm

Still getting the same error. It first says this that it failed to pick it up from the primary and then it says the same for the alternate and finally it gives this error message down here. I am really not sure what to do at all.

Wars of Liberty Updater - v1.4
Current Wars of Liberty Installation:
C:\Users\Jason\Desktop\test\bin

Fetching update info file...
An error has occurred while attempting to perform
that operation

java.net.SocketException: Unexpected end of file from server
sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
org.apache.commons.io.FileUtils.copyURLToFile(FileUtils.java:1506)
wolUpdater.Updater.downloadXML(Updater.java:345)
wolUpdater.Updater.main(Updater.java:97)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
java.lang.reflect.Method.invoke(Unknown Source)
org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
 
User avatar
Daniel Pereira
Wars of Liberty Team
Wars of Liberty Team
Posts: 109
Joined: Sun Mar 12, 2017 2:20 am

Re: Problems with Updater

Tue Jul 04, 2017 4:33 pm

Apparently, for some reason, the connection is being closed either on your end or on the server's end...

Are you sure that the firewall isn't blocking the updater or the JRE executable (which should be located at C:\Program Files\Java\jre<version here>\bin\java.exe and javaw.exe)? Also, do you connect to internet using some sort of VPN or proxy?

If, even after unblocking both the updater and the JRE executables, the error still persists, then all I can recommend you is installing the patches manually. The links for manual installation can be found at the Updater thread.
Image
 
User avatar
Hoffenheim
Topic Author
Whipped Slave
Whipped Slave
Posts: 5
Joined: Mon Jul 03, 2017 3:15 pm

Re: Problems with Updater

Thu Jul 06, 2017 7:32 pm

I manually installed the patch and hotfixes but I seem to have a different versions with my friend who has the installer working. Tbh I just really want the patch to work.

Who is online

Users browsing this forum: No registered users and 2 guests