This is the official forum for the free, fan-made Age of Empires III modification, Wars of Liberty.

Welcome to the New Forum

We hope you enjoy the official new forum of the Wars of Liberty mod for Age of Empires III! Visit this thread to get acquainted with the new forum, and let us know if there's anything we can fix. Feel free to dismiss this message at any time by clicking the "X" in the top right corner.

Thanks!
The Wars of Liberty Team

Forum rules

  • Welcome to The Hospital! This forum is for bugs and error reporting.
  • The official language in this forum is English.
  • Be nice to other members, don't spam comments or smilies, and don't do anything illegal.
  • Posts that don't fit this forum will be moved or deleted.
 
User avatar
Danagossauro
Topic Author
Mooing Cow
Mooing Cow
Posts: 4
Joined: Thu Oct 26, 2017 8:51 pm

Game crashing on start

Mon Jul 29, 2019 8:10 pm

I installed a fresh copy of AoE3 from steam, and it ran flawless, then i installed the mod, ran it, update it and ran it once more, all of that went well
But now every time i open the game the it would just quit during the loading screen, sometimes it will say "initialization failed"
I tried launching from steam, from the desktop shortcut, and from the age3y.exe, in all possible compatibility modes available

I deleted the game and ALL its files and did it all again, still nothing
Please helppppppp
 
User avatar
Banyana
Volunteer
Volunteer
Posts: 361
Joined: Mon Aug 21, 2017 3:23 pm
Location: Germany
Favorite Civilization: Swiss
ESO: Banyana
Steam: Dr. Maxy
Contact:

Re: Game crashing on start

Mon Jul 29, 2019 8:17 pm

Youve done something wrong xD
1. Never press any button while in loading screen. Let the game load to 100%
2. Run the mod as Admin
3. recheck you have installed the mod into the /bin folder
4. Did you start TAD once before installing the mod ?
5. What operating System are you using?
6. What did you do on your PC between the time you updated it, it ran without any problem, and now?
Smile like a Banyana... Image
 
User avatar
Danagossauro
Topic Author
Mooing Cow
Mooing Cow
Posts: 4
Joined: Thu Oct 26, 2017 8:51 pm

Re: Game crashing on start

Mon Aug 05, 2019 12:16 am

1. Done
2. Also done
3. Yep
4. Yes, i did
5. Windows 8.1 x64 (it is installed in the Archive Files x86 as usual)
6. I installed the mod, ran it, played a game, quit, and then some hours late it wouldn't start, didn't change anything

I deleted the personalities file in the My Games/Wars of Liberty/AI3 as was asked during the update

I tried to play it again today, it started after like five or six tries, played it again a couple of games, now it won't start after like 20 tries, even restarted the computer
I find it quite strange as yesteryear i installed the mod on another computer and it never caused any problems

Anyway, thanks for the help
 
User avatar
Banyana
Volunteer
Volunteer
Posts: 361
Joined: Mon Aug 21, 2017 3:23 pm
Location: Germany
Favorite Civilization: Swiss
ESO: Banyana
Steam: Dr. Maxy
Contact:

Re: Game crashing on start

Mon Aug 05, 2019 12:18 am

Windows 8 is your problem.
Smile like a Banyana... Image
 
User avatar
Danagossauro
Topic Author
Mooing Cow
Mooing Cow
Posts: 4
Joined: Thu Oct 26, 2017 8:51 pm

Re: Game crashing on start

Mon Aug 05, 2019 12:23 am

Wow, that was a fast response
So, yeah, thanks, i was planning on update to W10 anyway xd
 
User avatar
Banyana
Volunteer
Volunteer
Posts: 361
Joined: Mon Aug 21, 2017 3:23 pm
Location: Germany
Favorite Civilization: Swiss
ESO: Banyana
Steam: Dr. Maxy
Contact:

Re: Game crashing on start

Mon Aug 05, 2019 1:10 am

Do that, best thing you can
No problem
And yes i try to answer ASAP
Smile like a Banyana... Image

Who is online

Users browsing this forum: No registered users and 2 guests