This is the official forum for the free, fan-made Age of Empires III modification, Wars of Liberty.

Welcome to the New Forum

We hope you enjoy the official new forum of the Wars of Liberty mod for Age of Empires III! Visit this thread to get acquainted with the new forum, and let us know if there's anything we can fix. Feel free to dismiss this message at any time by clicking the "X" in the top right corner.

The Wars of Liberty Team

Forum rules

  • Welcome to The Hospital! This forum is for bugs and error reporting.
  • The official language in this forum is English.
  • Be nice to other members, don't spam comments or smilies, and don't do anything illegal.
  • Posts that don't fit this forum will be moved or deleted.
User avatar
Topic Author
Mooing Cow
Mooing Cow
Posts: 1
Joined: Thu Jul 11, 2019 3:52 pm

Failed to join game. and I'm all out of ideas

Thu Jul 11, 2019 4:14 pm


I recently tried to play this mod again with my friends after ~1 year of pause, so I updated it and everything seemed to be going fine until I got the infamous "Failed to join game" message (the game works just fine for the others, they can join each other and random games). During this time of pause I've moved to a new location, got a new ISP and a new router, the PC is the same.

The absurd thing, however, is that vanilla AOE works just fine, its just WOL that doesn't want to let me join people over ESO. I've tried searching for this problem but so far I haven't found anything.

I've tried googling for all sorts of fixes, but so far nothing has helped. These are the fixes I've tried:
- Running as administrator
- Using a VPN
- Forwarding ports on my router and unblocking them from my firewall
- Reinstalling WOL/AOE, making separate installations for both
- Clearing any traces of AOE/WOL with Revo Uninstaller and then reinstalling
- Trying a different connection (Mobile data)

I am completely out of ideas at this point, and single player is kind of getting boring :D
User avatar
Posts: 358
Joined: Mon Aug 21, 2017 3:23 pm
Location: Germany
Favorite Civilization: Swiss
ESO: Maxy147
Steam: Evil Morty

Re: Failed to join game. and I'm all out of ideas

Fri Jul 12, 2019 1:36 pm

Unlock your firewall.
Smile like a Banyana... Image
User avatar
Circle of Ossus
Posts: 473
Joined: Fri Mar 31, 2017 9:48 am
Location: Belgium
Favorite Civilization: Colombians

Re: Failed to join game. and I'm all out of ideas

Fri Jul 12, 2019 10:49 pm

I had such a problem at one point too. After a lot of retrying, I managed to join the game I no longer had the problem. Re-installing the game usually fixes most errors too.
AI game on patch 1.0.11b (and onwards): viewtopic.php?f=4&t=1981
Swiss UA proposal (obsolete?): viewtopic.php?f=8&t=768&p=6612#p6612

Who is online

Users browsing this forum: No registered users and 22 guests