This is the official forum for the free, fan-made Age of Empires III modification, Wars of Liberty.

Welcome to the New Forum

We hope you enjoy the official new forum of the Wars of Liberty mod for Age of Empires III! Visit this thread to get acquainted with the new forum, and let us know if there's anything we can fix. Feel free to dismiss this message at any time by clicking the "X" in the top right corner.

Thanks!
The Wars of Liberty Team

Forum rules

  • Welcome to The Hospital! This forum is for bugs and error reporting.
  • The official language in this forum is English.
  • Be nice to other members, don't spam comments or smilies, and don't do anything illegal.
  • Posts that don't fit this forum will be moved or deleted.
 
User avatar
Iron Kaiser
Topic Author
Whipped Slave
Whipped Slave
Posts: 8
Joined: Wed Dec 20, 2017 1:42 am

Game loses sound, hanging ambient noise

Wed Dec 27, 2017 4:31 am

Hello WoL community! Loving the mod, having a great time with it.

I've got a weird situation that I'm hoping you might be able to help provide some answers. A friend of mine has recently installed the mod so we can play together, and in every game he plays, at about the five minute mark, all of his audio suddenly mutes. The one exception is a background ambient noise, like a wind sound or water sound (it changes). The ambient noise gets stuck on constant repeat. Even if you quit the game and go back to menu, the noise continues to stick on repeat while everything else is silent.

I've tried trouble-shooting him through everything, and I cannot figure out what the cause of this bug could be. I'm not experiencing the issue myself, and best as I'm aware, he followed my installation instructions perfectly. He's played on different maps, with different civs, and the same issue keeps coming up. We've played with different things in the options, like turning Music/Sound off and on both before and after the glitch, and turning off equalization, but nothing's working so far.

Does anybody have any ideas as to what might be causing this?
Thanks
 
User avatar
Iron Kaiser
Topic Author
Whipped Slave
Whipped Slave
Posts: 8
Joined: Wed Dec 20, 2017 1:42 am

Re: Game loses sound, hanging ambient noise

Fri Dec 29, 2017 1:02 am

Update: my friend has tried installing this on two separate computers, and he ran into the same issue on both computers. Here's what we've found that has been most interesting. If we go into the files and delete the "wotta>music>peace" folder, where all the custom gameplay music is, then the game works for him. The first custom-civ song will play, and then there's no music, obviously, but the audio will no longer freeze up. Unit quotes and ambiance will play freely throughout the game. If I'm gathering this right, it appears that the audio freezes as soon as the game tries to make the switch from the civ-unique song to general-gameplay-song #1. But even if we know the when, I still don't know why, or how to fix it. Still figuring this out...
 
User avatar
Rampo
Horse Grenadier
Horse Grenadier
Posts: 328
Joined: Sun Jul 02, 2017 2:33 pm
Location: Vung Tau City, Vietnam
Steam: BG_Rampo

Re: Game loses sound, hanging ambient noise

Fri Dec 29, 2017 2:30 am

I've detected this problem like you've posted here, Iron Kaiser .Maybe there's some event that doesn't include the sound here, for example:
1: You train 10 spies or more
2: If you choose religion "animism", and research tech "Spirit Possesion"
3: if you choose religion "Judaism", but i don't know what tech make that problem occur, i remember when i used this religion in Egypt...
4: When your Trading Post or TC is destroyed by enemies (Or you press delete to self destruct your TC or Trading post when these building is on building)
...
is that your problem occur when you have done like these?
The only and temporary tip to fix this is make the sound come to Battle mode by make 3 or more of your military unit to attack enemy's Trading post or TC and retreat (eka hit and run tactic)
ESP: Sin amor, el mundo se hundirá en la guerra
POR: Sem amor, o mundo afundará na guerra
ENG: Without love, the world will sink in war

BG Rampo
 
User avatar
Iron Kaiser
Topic Author
Whipped Slave
Whipped Slave
Posts: 8
Joined: Wed Dec 20, 2017 1:42 am

Re: Game loses sound, hanging ambient noise

Sat Dec 30, 2017 3:34 am

No, I don't think that in-game events like training units or researching technology have anything to do with it. Even in games where my friend has done nothing but wait, the audio will still go bad as soon as the music switches from the unique civ music to the regular WoL music. And it's all the audio that goes bad, even the voice lines and the background noise. Starting a battle to switch the game to battle music, unfortunately, doesn't work. So far, the only "fix" we've found has been to delete the music folder. I'm hoping we'll come up with a better solution soon.

Thanks for the advice, though. I appreciate it.

Who is online

Users browsing this forum: No registered users and 1 guest