This is the official forum for the free, fan-made Age of Empires III modification, Wars of Liberty.

Welcome to the New Forum

We hope you enjoy the official new forum of the Wars of Liberty mod for Age of Empires III! Visit this thread to get acquainted with the new forum, and let us know if there's anything we can fix. Feel free to dismiss this message at any time by clicking the "X" in the top right corner.

Thanks!
The Wars of Liberty Team

Forum rules

  • Welcome to The Town Hall! This forum is for news and discussion about anything related to WoL. You can ask any WoL-related questions here.
  • The official language in this forum is English.
  • Be nice to other members, don't spam comments or smilies, and don't do anything illegal.
  • Posts that don't fit this forum will be moved or deleted.
 
User avatar
Mr_ZirBa
Topic Author
Mooing Cow
Mooing Cow
Posts: 1
Joined: Mon Oct 09, 2017 5:06 pm

Desync or Extreme lag with the mod's multiplayer

Mon Oct 09, 2017 5:20 pm

Me and my friend currently have a problem with the multiplayer aspect of the game/mod.(Just putting a note here that, yes the game works fine in multiplayer without the mod. We tried playing the mod in singleplayer and we were amazed at what the mod implemented.
We got all excited to play this together and even with other friends. But when we created a game in LAN with Gameranger we got a big problem.

Once the game loaded in we noticed that every so often we got a lagspike where we could still move our screens and select things they just wouldn't move at all. So basically it looked like the whole game was on a standstill but it wasn't. We tried fixing this by changing civs, removing and adding AI and trying different maps. When that all didn't work we tried using a program called Tunngle which is basically the same as gameranger. We didn't get that same lag as in Gameranger however we got the problem where it Out Of Synced (OOS) us. And again we tried the same thing as we did in gameranger. Then we tried running the game as administrator and windows xp (service package 3), changing the videocard the game uses, tried running Gameranger on a different windows. And even did a full reinstall of the mod AND game to see if that would maybe fix it. We also did the standard thing of trying to turn of our firewalls.

We tried litterly everything we can come up with but we still don't know how to fix it. Usually after trying so hard I would give up but I like this mod too much to do so. I tried looking on the forums but no one really got an answer which really bumped me out. so I created this account to see if anyone would know how to fix this because me and my friends really want to play this mod and it now would feel a bit like downgrading the game if we would go back to the normal game.

If you could help us please let me know as soon as possible. Thank you.
 
User avatar
lascupa0788
Mooing Cow
Mooing Cow
Posts: 1
Joined: Mon Oct 09, 2017 10:32 pm

Re: Desync or Extreme lag with the mod's multiplayer

Mon Oct 09, 2017 10:39 pm

Playing in the official ESO servers with friends who live whole countries away, we only experience a very occasional lagspike or OOS. Most games, AI or not, everything works fine. In fact, cumulatively, I expect each of us has gotten at least 40-50 levels with different homecities in the mod.

That would leave me to believe that there is something weird happening with the added variable of the tunneling program. Does ESO not work for you guys? If it doesn't, then I suppose the only thing I can think of that might help is using a different program, such as the classic Hamachi perhaps.
 
User avatar
Dr Roach
Blandengue
Blandengue
Posts: 137
Joined: Sat May 13, 2017 9:09 pm

Re: Desync or Extreme lag with the mod's multiplayer

Mon Oct 09, 2017 10:54 pm

Damnation, is the hospital topic invisible or what?

Anyway, if you choose a regular map when setting up a LAN game, then the game OOSs when you start the match. In order to fix this, copy the maps you want to play on to the custom map folder, rename them, and then select them from the custom map list. The lag spikes will be present, but that's a given- try playing with fewer AI players.
 
User avatar
leandresca
Mooing Cow
Mooing Cow
Posts: 1
Joined: Tue Oct 10, 2017 1:35 pm

Re: Desync or Extreme lag with the mod's multiplayer

Tue Oct 10, 2017 1:42 pm

i have the same problem (OOS) with my friend in ESO server. Every time we start a game after about 13 minutes OOS.

Who is online

Users browsing this forum: No registered users and 3 guests